玩運彩練小喂

Ubuntu 16.04 安裝 PHP 5.6

https://commons.wikimedia.org/wiki/File:PHP-logo.svg

若你使用 Ubuntu 16.04 LTS 要安裝 PHP。會發現使用apt-get安裝下來的版本都是 PHP 7,指定安裝的版本也無法安裝 PHP 5.X 的版本。這是因為 Ubuntu 16.04 LTS 官方預設的 PHP package repo 已經都更新為 PHP 7 了。

但是有一些舊的專案或 Framework 還不支援 PHP 7。還是必須要使用 PHP 5.X 的版本才能運作。為了解決此問題,下面示範如何透過第三方的 PPA 安裝 PHP 5.6 。

確認目前已安裝的 PHP 版本,若是已經使用 apt-get install 安裝 PHP 7 建議先移除已安裝的 PHP 。

增加 PPA repo

安裝 PHP 5.6

檢查 PHP 安裝的版本

若要調整設定檔 php.ini ,設定檔的路徑如下

透過上述的方式我們已經成功在 Ubuntu 16.04 LTS 上安裝 PHP 5.6 了。除了能安裝 PHP 5.6 之外,我們同時也能夠並存 PHP 7 和 PHP 5.6 。只要把剛剛安裝的 php5.6 改為你要安裝的版本 ex : php7.0 。下面指令示範如何安裝 php7.1。

安裝 php 7.1

PHP 切換版本

參考資料來源:
askubuntu.com-cant install php5 on ubuntu 16 04
How to Install PHP 5.6 or PHP 7.1 on Ubuntu 16.04, 14.04 using PPA

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *